Started by Shaleena AgarwalSep 7, 2021

Open
Issue when updating composer (dev-update-flysystem)

0 VIEWES 0 LIKES 0 DISLIKES SHARE
0 LIKES 0 DISLIKES 0 VIEWES SHARE

I am trying to update the packages using composer but this error message is poping-up and I have no idea what it means and how to resolve it.

I do not have a branch called "dev-update-flysystem" or "update-flysystem".

Error Message :-

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Can only install one of: foobar/course-bundle[dev-develop, dev-update-flysystem].
- Can only install one of: foobar/course-bundle[dev-update-flysystem, dev-develop].
- Installation request for foobar/course-bundle dev-develop -> satisfiable by foobar/course-bundle[dev-develop].
- Installation request for foobar/course-bundle (locked at dev-update-flysystem, required as dev-develop) -> satisfiable by foobar/course-bundle[dev-update-flysystem].

And here is my composer requirements:-

"require": {
"php": ">=7.1",
"foobar/core-bundle": "dev-develop",
"foobar/course-bundle": "dev-develop",
"foobar/exam-bundle": "dev-develop",
"foobar/exception-reporting-bundle": "dev-master"
}

I also tried clearing the composer cache using

php composer clear-cache

Is there a way to resolve this issue without having to setup the whole project again?

0 Replies

You must be Logged in to reply
Techiio

Techiio is on the journey to build an ocean of technical knowledge, scouring the emerging stars in process and proffering them to the corporate world.

Follow us on:

facebooklinkdeintwitter

Subscribe to get latest updates

You can unsubscribe anytime from getting updates from us
Copyright techiio.com @2020 Kolkata, India
made with by Abhishek & Priyanka Jalan
Copyright techiio.com @2020
made with by Abhishek & Priyanka Jalan